Version pre 2.x of keepalive which are shipped with the Ubuntu18 Repository will crash. You'll have to configure a higher Version from source by yourself.

https://github.com/acassen/keepalived/issues/836

https://www.keepalived.org/download.html

"/lib/systemd/system/keepalived.service"

[Unit]
Description=LVS and VRRP High Availability Monitor
After=network-online.target syslog.target
Wants=network-online.target

[Service]
Type=forking
PIDFile=/run/keepalived.pid
KillMode=process
EnvironmentFile=-/usr/local/etc/sysconfig/keepalived
ExecStart=/usr/local/sbin/keepalived $KEEPALIVED_OPTIONS
ExecReload=/bin/kill -HUP $MAINPID

[Install]
WantedBy=multi-user.target

Continue reading...